Twitter Bootstrap を試すために、 jQueryGoogle Loader で読み込んでみたところ、 どうもうまく動作せず、すったもんだしたあげく、 以下のようなファイルを作って確認してみると、 読み込んできている jQuery のバージョンが 1.7.1 であることがわかりました。
<!DOCTYPE html>
<html lang="ja">
<head>
  <script type="text/javascript" src="http://www.google.com/jsapi"></script>
  <script type="text/javascript"><!--
    google.load("jquery", "1");  
  //--></script>
  <script type="text/javascript">
    $(function() {
      alert($.fn.jquery);
    });
  </script>
</head>
<body id="pagetop">
Hello jQuery!
</body>
</html>
 なんでやねん!って思って デベロッパーガイド を 見てみると、昔はあったはずの Google Loader を使用した ロード方法の記載がなくなっていました orz

 では、今はどうやって Google から JavaScript をロードすることが推奨されているかというと、 以下のように記載されています。
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
 jQuery を 読み込んでくる場合の例ですが、 URL の中にバージョン番号が練り込まれています。
 上記の例では意識せずに最新版を読み込んでくることができなさそうですが、 以下のように記述することで、最新版 (1.9.1) を読んでくることができました。
<script src="//ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>
# 「 1.9 」ではだめです。「 1 」でないといけません。

 なんか釈然とせんなぁ… そもそも Google Loader を 使うことを推奨しなくなったのはいつからなんでしょう?

 しかも、四苦八苦しているのはなにもこの話だけではなかったりする。。。 Twitter Bootstrap も かなり難物で… (^^;
jQuery ポケットリファレンス (POCKET REFERENCE)
鶴田 展之 著
( 技術評論社 )
¥91
Ellinikonblue.com Weblog 「 HTML5 習得目指して迷走中… jQuery 読み込みでまずこける orz 」